Loksim3D 2.9.6

  • Hallo,

    aufgrund des hier beschriebenen Problems, werden wir schon jetzt eine neue Loksim Version 2.9.6 veröffentlichen X/


    Hintergrund: Ich habe leider vergessen, die verwendete crashrpt Bibliothek mit VisualStudio 2019 neu zu kompilieren. Deshalb verwendet diese noch die Abhängigkeiten von Visual Studio 2013. Wir hätten nun entweder das Setup anpassen müssen, sodass auch die VS2013 Redistributables installiert werden. Oder das Problem im Code und korrigieren und veröffentlichen eine neue Version. Wir haben uns für zweiteres entschieden.


    Ein kurzer Betatest der neuen Version wurde schon abgeschlossen. Ich möchte dieses Mal so verfahren, dass ich die neue Version vorerst nur hier verlinke, und wenn keine Probleme auftreten werde ich sie in ein paar TAgen auch auf der Homepage verlinken:

    https://www.loksim3d.de/de/add…m3d-296-setup-vollversion


    Neben dieser Korrektur, haben es damit auch einige andere Kleinigkeiten in die neue Version "geschafft". Der größte Punkt davon ist dabei die Möglichkeit eine Lizenz-Datei für Loksim-Dateien zu definieren (auch kann dafür ein Standardwert im LoksimEdit gesetzt werden). Außerdem kann man .l3dmeta Dateien verwenden um für externe Objektformate / Texturen ebenfalls eine Lizenz zu definieren. Genaueres habe ich in der beigelegten LoksimDetailDoku.pdf dokumentiert. Wenn die Beschreibung unklar ist - bitte einfach fragen. Dann verbessere ich auch die Doku :)


    lg

    Lukas


    PS: Noch eine Anmerkung zu den Versionsnummern: Die nächsten Versionen werden (voraussichtlich) 2.10, 2.11, etc. heißen und nur bei Bugfixversionen (wie dieses es ist), wird die 3. Stelle zur Versionierung genutzt. Damit sollte es in Zukunft (wieder) klarer sein, was eine "richtige" neue Version ist, und was eher eine kleine Zwischenversion

  • Hallo,


    habe die neue Version ausprobiert und bisher kam es zu keinem Absturz / Fehler o.ä.


    Bei der Vorgängerversion hatte ich innerhalb weniger Tage immer wieder Abstürze während der Fahrt auf Strecken, die sonst immer reibungsfrei funktionieren.


    LG

    Benjamin

  • Habe mich mal an 2.9.6 gewagt, mit dem Ergebnis , das es diese Fehlermeldung gibt ( siehe Screenshots ).Bild 1 normal und mit JA bestätigt, dann erscheint im Bild 2 die Meldung .





    die Version 2.9.5 lies sich hingegen vor Wochen problemlos installieren. Es wurden am Laptop in der Zwischenzeit keine Änderungen vorgenommen.


    Ist den 2.9.6 nun offiziell ( Download auf Loksim Homepage ) oder noch nicht ?


    Gruss Ingo


    Nachdem ich nun beide Visual C... Versionen manuell installiert habe , lief der Installationprozess durch. Warum dann allerdings nochmals Visual C installiert wurde kann ich nicht nachollziehen.


    Gruss Ingo

  • Habe mich mal an 2.9.6 gewagt, mit dem Ergebnis , das es diese Fehlermeldung gibt ( siehe Screenshots ).Bild 1 normal und mit JA bestätigt, dann erscheint im Bild 2 die Meldung .

    Ich gehe davon aus, dass Du die .zip Datei nicht entpackt hast vor der Installation? Dies ist unbedingt nötig, sonst werden die VisualC++ abhängigkeiten nicht gefunden (Order LoksimDependencies muss existieren)

  • Moin , wo du das sagst....... Asche über mein Haupt.... Ja du hast den Nagel auf den Kopf getroffen. Funktioniert doch. Sorry.

    LG Ingo