Umschaltung bei Signalen

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Die Betreiber dieser Seiten nehmen den Schutz Ihrer persönlichen Daten sehr ernst. Wir behandeln Ihre personenbezogenen Daten vertraulich und entsprechend der gesetzlichen Datenschutzvorschriften. Bitte beachten Sie unsere Datenschutzerklärung: https://www.loksimulatoren.de/index.php/PrivacyPolicy/

    Bitte benutzen Sie diese Seite nur, wenn Sie mit unserer Datenschutzerklärung einverstanden sind.

    • Umschaltung bei Signalen

      Hallo zusammen,
      mir ist in letzter Zeit aufgefallen, dass beim Umschalten von Signalen bei Abfahrt im Simulator sofort ein Wechsel von Rot auf Grün stattfindet. Ich habe jedoch jetzt des Öfteren gesehen, dass in der Realität von Rot auf grün erst Gelb und danach Grün geschalten wird, oder auch bei anderen Signalwechsel. Also nicht sofort. Außerdem bin ich in YouTube auf folgenden Link gestoßen, der das nochmal zeigt: youtube.com/watch?v=lhr83QuB9CU

      Also dazu mein Vorschlag: Beim Umschalten eine kleine Verzögerung und/oder ein Umschalten in der Reihenfolge einbauen. -Damit könnte ein wenig mehr Realität ins Spiel gebracht werden.-


      Ist sowas möglich oder ist dafür zu viel Programmieraufwand nötig?

      (Falls es bereits ein solches Thema gibt, bitte gerne verlinken -nach Suche nicht gefunden-)
      (Falls ich mich beim Umschalten der Signale geirrt haben sollte, bitte auch gerne anmerken)


      Grüße Toby
      Wofür benötige ich eine Signatur? Liest ja sowieso keiner! :)
    • Hallo Toby,

      die Anzeige bei Ks-Signalen ist abhängig vom nachfolgenden Signal. Wenn Du willst, dass dieses gelb angzeigt, muss das nächste Hauptsignal rot sein, erst wenn dieses gelb oder grün wird, wird das davor auch grün. Werden die Signale zeitgleich direkt in einem Stellvorgang auf Fahrt gestellt, erfolgt der Wechsel direkt von rot auf grün. Die Schaltung Rot -> gelb -> grün lässt sich also nicht verallgemeinern und ist abhängig von der Einstellung der Fahrstraße(n) und der Verarbeitungsgeschwindigkeit des Stellwerks. Bei der Berliner S-Bahn schalten die Signale häufig von rot -> grün blinkend -> grün Standlicht.

      Alternativ kannst Du dir selbst behelfen und etwas tricksen, indem Du ein Signal so veränderst, dass das grüne Licht nur angezeigt wird, wenn auch der Abfahrts- und/oder Türschließauftrag vorliegt und ansonsten (fälschlicherweise) unabhängig von der Stellung des nächsten Hauptsignals immer gelb angezeigt wird. Dabei sollte das nächste Signal aber noch nicht in Sichtweite sein, sonst leidet der Realismus.

      Im Übrigen gibt es weitere Formen der "Umschaltverzögerungen". Bei älteren Relaisstellwerken ist häufig zu beobachten, dass die rote Lampe aus- und erst nach etwa 1s die grüne angeht. Bei neueren EStw der SICAS-Reihe schaltet teilweise (z.B. Berliner U-Bahn) hingegen erst das grüne Licht ein und etwa 1s später das rote ab, es leuchten also beide für einen Moment zeitgleich.

      Gruß, Klaus
    • Hallo Klaus,
      danke für die schnelle Antwort.

      KlausN schrieb:

      die Anzeige bei Ks-Signalen ist abhängig vom nachfolgenden Signal. Wenn Du willst, dass dieses gelb angzeigt, muss das nächste Hauptsignal rot sein, erst wenn dieses gelb oder grün wird, wird das davor auch grün. Werden die Signale zeitgleich direkt in einem Stellvorgang auf Fahrt gestellt, erfolgt der Wechsel direkt von rot auf grün. Die Schaltung Rot -> gelb -> grün lässt sich also nicht verallgemeinern und ist abhängig von der Einstellung der Fahrstraße(n) und der Verarbeitungsgeschwindigkeit des Stellwerks. Bei der Berliner S-Bahn schalten die Signale häufig von rot -> grün blinkend -> grün Standlicht.
      Dass das Signal im Video erst gelb angezeigt hat, da das nächste Signal Halt anzeigt ist klar. Ich glaube, dass ich mich da nicht verständlich ausgedrückt habe.


      KlausN schrieb:

      Im Übrigen gibt es weitere Formen der "Umschaltverzögerungen". Bei älteren Relaisstellwerken ist häufig zu beobachten, dass die rote Lampe aus- und erst nach etwa 1s die grüne angeht. Bei neueren EStw der SICAS-Reihe schaltet teilweise (z.B. Berliner U-Bahn) hingegen erst das grüne Licht ein und etwa 1s später das rote ab, es leuchten also beide für einen Moment zeitgleich.
      Das ist schon eher, das was ich wollte. Dass nicht sofort der nächste Signalbefehl kommt, sondern, dass (vgl. Video) erst der Neue und dann der alte Signalbefehl angezeigt wird. Und somit eine Umschaltverzögerung und -meines Erachtens- mehr Realität in gewissen Bereichen bietet.
      Kann man da auch ein wenig "tricksen" oder müsste das vom Programm selber gesteuert werden?

      Grüße Tobi
      Wofür benötige ich eine Signatur? Liest ja sowieso keiner! :)
    • Hallo Toby,

      Dein 'Problem' ist bekannt. Programmseitig geschieht folgendes:
      Beim Signalbildwechsel wird einfach ein Objekt gegen ein anderes getauscht und das unmittelbar. Hier jetzt über 'schwarz' einen Lichtwechsel zu programmieren und das auch für den Signalbauer verfügbar zu machen halte ich für sehr aufwendig.
      Ich möchte da lieber meine leider knappe Zeit für andere Dinge im Loksim verwenden. Da ist noch die Fahrkante offen und auch die Bremse... Von den anderen Baustellen mal zu schweigen.
      Leider kann ich Dir für meine Wenigkeit keine besser Nachricht geben.

      Gruss
      Uwe
      --
      Wenn du die Götter zum Lachen bringen willst, mach’ einen Plan.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von taler () aus folgendem Grund: Fipptehler

    • Neu

      Hallo Tobi,

      Toby schrieb:

      Das ist schon eher, das was ich wollte. Dass nicht sofort der nächste Signalbefehl kommt, sondern, dass (vgl. Video) erst der Neue und dann der alte Signalbefehl angezeigt wird. Und somit eine Umschaltverzögerung und -meines Erachtens- mehr Realität in gewissen Bereichen bietet.Kann man da auch ein wenig "tricksen" oder müsste das vom Programm selber gesteuert werden?

      Grüße Tobi

      Ich hatte mal etwas experimentiert und man könnte das mit Zp9 oder Zp10 austricksen, wenn man das nicht explizit als Signalbegriff brauch. Je nach Fall (Alt- oder Neutechnik) wäre dann folgendes zu tun:

      - Alttechnik (für 1s keine aktive Signaloptik)
      1. Fahrtbegriffobjekte im Signal als "Sim::Hp1 && Sim::Zp10" definieren
      2. im Fahrplan den Türschließauftrag so einstellen, dass er eine Sekunde nach Fahrtstellung des Signals kommt
      3. mit Fahrtstellung erlischt Hp0, mit (virtuellem) Türschließauftrag leuchtet Hp1 auf
      - Neutechnik (für 1s beide Signaloptiken)
      1. Haltbegriffobjekte im Signal als "!Sim::Zp10" definieren
      2. im Fahrplan ebenfalls den Türschließauftrag so einstellen, dass er eine Sekunde nach Fahrtstellung des Signals kommt
      3. mit Fahrtstellung leuchtet Hp1 auf, mit (virtuellem) Türschließauftrag erlischt Hp0
      @taler:

      Ich möchte hier dennoch einen entsprechenden Vorschlag anbringen, der diesen Workaroung vermeidet und u.U. auch für andere Anwendungsfälle geeignet ist:



      Einfügen eines zusätzlichen Eingabefeldes im Gruppenobjekt-Editor unterhalb des Feldes für den Blinkintervall. "Verzögertes Ein-/Ausblenden", bei Eingabe von 0 wird das Objekt wie bisher ein- oder ausgeblendet, bei negativen Werten entsprechende Sekunden verzögert ausgeblendet und bei positiven Werten entsprechende Sekunden verzögert eingeblendet. Falls jetzt jemandem ein Fall einfällt, bei dem Verzögerung für beide Fälle zwingend notwendig wäre (und nicht über die Verzögerung eines jeweils anderen Objektes gelöst werden kann), müsste man das aufsplitten.
      Denkbar wäre noch eine Checkbox, die die Verzögerung auch beim Blinken anwendet (dann müssten aber auch Sekundenbruchteile umgesetzt werden), somit wären dann noch ungleichmäßige Blinkintervalle möglich, wie sie bei Signalen ja auch häufig vorkommen.

      Gruß, Klaus