Package erstellen: Dateien werden nicht gefunden

    • Ist kein Fehler

    Einsatz von Cookies
    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Datenschutz
    Wir nehmen den Schutz Ihrer persönlichen Daten sehr ernst und behandeln Ihre personenbezogenen Daten vertraulich und entsprechend gesetzlicher Datenschutzvorschriften. Bitte beachten Sie unsere Datenschutzerklärung. Durch die Nutzung unserer Seite erklären Sie sich mit unserer Datenschutzerklärung einverstanden.

    • Package erstellen: Dateien werden nicht gefunden

      Loksim-Version: 2.9.4
      Programmteil: andere
      Betriebssystem: Windows 10
      Rechnerkonfiguration:
      Fehlerbericht gesendet:
      _________________________

      Hallo zusammen,

      ich wollte erstmals unter Loksim-Version 2.9.4 ein Streckenmodul zur Absicherung packen. Kurz nachdem ich auf "Abhängige Dateien ermitteln" klicke, erscheint ein Fenster mit einer Liste von nicht gefundenen Dateien (ca. 50 von insgesamt 2300 Dateien). Einige dieser Dateien existieren tatsächlich nicht, dabei handelt es sich aber nur um Vorschaubilder von (Gruppen-)Objekten. Andere Dateien existieren allerdings und sind in dem anschließend erstellen Package auch enthalten. Sie werden auch in der Strecke problemlos dargestellt. Es handelt sich immer um die gleichen Dateien, die nicht gefunden werden können.

      Die Ursache liegt nicht in meinem Streckenmodul, der Fehler tritt bei jeder anderen Strecke auf, bei der ich es bisher ausprobiert habe. Nach Absprache mit einem anderen Mitglied kann ich auch sagen, dass der Fehler nicht bei mir liegt, sondern bei mehreren Nutzern (ggf. allen) auftreten muss.

      Ist dies bereits bekannt? Tritt das Problem bei allen oder nur einigen Nutzern auf? Und: Kann es bei der Installation der gepackten Strecke auf einem anderen Rechner zu Problemen kommen (da ja die nicht gefundenen Dateien im Package enthalten sind)?

      Vielen Dank im Vorraus,
      MfG
      Simon
    • Hallo Simon

      Wenn die Vorschaubilder fehlen, und es handelt sich dabei um Deine eigenen Dateien, dann würde ich die VorschauBilder aus der Loksim Objekt- oder Gruppendatei einfach löschen. Bei Vorschaubildern anderer Autoren, einfach zu Kenntnis nehmen, und es so lassen. Das Fehlen der Bilder ist unschädlich.

      Bei .dae Dateien kommt es vor, das die Bilder .png oder .dae als fehlende Dateien aufgelistet sind, aber im Package enthalten sind, das kannst Du ignorieren.

      Bei allen anderen Dateien dürfte es zu Falschdarstellungen kommen, und die müßtest Du dann bereinigen, und in einem Verzeichnis von Dir neu speichern, nicht vom Originalautor.

      Gruß
      Martin
      Per E-Mail nicht erreichbar .
    • Hallo Martin,

      dass mit den Vorschaubildern sehe ich jetzt auch nicht als wirkliches Problem, können wir also außen vor lassen. Bei den Dateien, die nicht gefunden werden können, aber vorhanden sind, handelt es sich gar nicht um *.png- oder *.dae-Dateien, sondern um *.l3dobj- oder *.l3dgrp-Dateien.

      Zu Falschdarstellungen kommt es allerdings nicht. Die (Gruppen)-Objekte, die nicht gefunden werden können, werden problemlos angezeigt. Und ein Fehler im Dateisystem ist m. M. n. ausgeschlossen, da ich (wie oben bereits angesprochen) ein anderes Mitglied gebeten habe, das bei sich mal auszuprobieren und dort das gleiche Problem auftritt.

      MfG
      Simon
    • Klar, da hätte ich auch selbst drankdenken können. Die Meldung wird als *.txt-Datei ausgegeben. Ich habe sie so wie sie ist abgespeichert und hochgeladen. Zur Meldung

      Das Problem ist ja streckenunabhängig, ich habe es mit dem Streckenmodul \Strecken\PSB100\Wiesenanger.l3dstr (aus dem Package PSB111.5) versucht, insgesamt sind hier 1622 Dateien abhängig. Wenn ich das Package erstelle, sind alle Dateien (ausgenommen die Vorschaubilder) später enthalten.

      MfG
      Simon
    • Hallo Miguel,

      jetzt seh' ich es auch. Und ich habe mich schon gewundert, warum einige Dateien mit "-->" gekennzeichnet sind und andere nicht. Ich dachte, dass hätte den Hintergrund, dass alle mit "-->" gekennzeichneten Dateien aus dem gleichen Verzeichnispfad stammen wie die jeweils übergeordnete Datei.

      Hier habe ich mal wieder unter Beweis gestellt, dass ich bei einfachen Dingen zu kompliziert denke.

      Danke an dich und an Martin für eure Hilfe! Sorry, darauf hätte ich wahrhaftig selbst kommen können!

      MfG
      Simon