Zugzielanzeiger nicht (mehr) verwendbar?

  • Hallo an alle


    Die Suche nach einem schon vorhandenen Beitrag zur Überschrift konnte ich auf die Schnelle nicht finden.

    Beim Streckenbau und den vielen Möglichkeiten, die der Loksim samt seiner Editoren kann, ist folgendes "passiert":

    Ich habe die schon relativ "alten" Zugzielanzeiger (kurz ZZA) von JBP als Anzeigen auf den Bahnsteigen nutzen wollen, die sowohl immer noch im Downloadbereich verfügbar als auch in der Edit-Doku beschrieben sind, doch die gemachten Eingaben im Objekt werden nicht übernommen/gespeichert, obwohl mich Dominik auch schon unterstützt hat, denn seine Anzeigen auf der Ermstalbahn funktionieren (sind aber Klaus seine Daisy´s), das Prinzip sollte sich doch aber nicht unterscheiden.

    Könnte es deshalb sein, dass im Programm seit der Erstellung der ZZA´s unter vermutlich 2.8.x was geändert wurde, sodass diese nicht mehr "erste" Wahl für eine solche Aufgabe sind :?::?::?:


    Für Hinweise danke ich wie immer herzlich im Voraus.

    Beste Grüße

    Andre

  • Hallo Namensvetter.

    Es wäre ganz gut wenn du die genauen Dateien benennen würdest die dir Probleme bereiten.
    Im Ordner der Zugzielanzeige befinden sich einige Dateien und ich habe nur eine davon ausprobiert.
    ZZA_digital_10.l3dgrp .. die geht bei mir mit der aktuellen Version.

    Gruß André

  • Hallo André


    Jepp. Dann mache ich noch irgendwas anderes falsch.

    Könntest du mir (evtl. per PN..., nein sorry Konversation) die Einträge im Objekt senden, damit ich ditte vergleichen kann.

    Das wäre bestimmt sehr hilfreich :thumbup:.


    Danke und beste Grüße

    AndreL

  • Mal eine grundlegende Frage. Möchtest du die Zugzielanzeige mit dr Sichtbarkeitsteuerung ansteuern?
    Wenn ja schreib hier mal deine Formeln rein.


    Gruß André

  • Hallo Namensvetter


    Es gibt dort nur ein kleines Problem, weswegen ich hier nicht öffentlich den String posten werde, aber du hast gleich Post und ich bitte um Verständnis. ;)


    Beste Grüße

    AndreL

  • Es gibt dort nur ein kleines Problem, weswegen ich hier nicht öffentlich den String posten werde [...]


    Was ist denn so geheim, als das man das nicht öffentlich posten kann? Lukas & Co können Probleme nur lösen, wenn das auch öffentlich erörtert wird.

  • PatrickR

    Added the Label Nicht reproduzierbar
  • Hallo Patrick


    Ich denke, du hast vollkommen Recht, es ist eher mein (Bediener-)Fehler als einer des Loksim. Somit könnte der Treat auch woanders hin verschoben oder geschlossen werden.

    "Geheim" ist es eigentlich nicht, jedoch befürchte ich einen "Aufschrei" Einiger hier im Forum. Deswegen möchte ich es nicht.

    Wir sind ja eh schon im Kontakt, deswegen erhälst du gleich Post und ich schrieb Andre´W auch schon eine PN dazu.


    Danke auch hier für´s Verständnis. :thumbup:

    Beste Grüße

    AndreL

  • Hallo Klaus


    "Geheim" ist es eigentlich nicht...

    Ich würde ja eher aufschreien, weil Du Hilfe für etwas willst, dass du aber in einem Freeware- und (zumindest bei den Addons) OpenSource-Projekt wie dem Loksim nicht öffentlich preisgeben willst.

    Das hat nichts mit "öffentlich" preisgeben zu tun, jedoch hast du mich damit auf eine Idee gebracht. Thx.


    Ich möchte aber auch betonen, dass es sich aller Wahrscheinlichkeit nach um eine Bedienerfehler und KEIN Fehler des Loksim handelt und damit wird der Treat gegenstandslos. Die Testläufe dazu sind aber noch nicht abgeschlossen und so viel Zeit muss sein.


    Beste Grüße

    AndreL

  • PatrickR

    Set the Label from Nicht reproduzierbar to Benutzerfehler
  • Ich habe es per PN geantwortet und möchte es auch hier nochmal sagen:


    Fehler und Problemmeldungen können gerne auch dann erstellt werden, wenn an fremden AddOns herumgebaut und herumgetüftelt wird. Es geht hier nicht darum, die Veränderung als "Endprodukt" irgendwann zu veröffentlichen, sondern um Probleme und (eigene) Fehler zu erkennen, zu verstehen und einen Lösungsweg zu finden, der später einmal auch anderen Nutzern bei ähnlichen Fehlern weiterhelfen kann.

  • Ich möchte dazu auch noch etwas sagen.

    Zum einen habe ich deine PN gelesen und werde dir die Tage antworten. Das kann aber etwas dauern da ich natürlich auch Zuhause Dinge zu erledigen habe.


    Was mir aber aufgefallen ist. Du hast ein Problem und man soll dir helfen.
    Da gehört es sich doch eigentlich das man dazu kommuniziert was man, womit, wie probiert hat,
    Also Loksim Version, Welches Addones in welcher Version wie und wo eingebaut.
    Das ich mir die Zeit genommen habe dir diese Infos aus der Nase zu ziehen ist meiner Gutmütigkeit geschuldet.
    Andere werden das nicht tun, und der Leidtragende bist dann du selbst.

    Also wenn man ein Problem hat und Hilfe sucht, mit Infos nicht geizen. Um so leichter hat man es ein Problem nachzuvollziehen.
    Und dann kann auch zeitnah und gezielt geholfen werden.


    Gruß André

  • Hallo an alle


    Zuerst PatrickR und AndreW: trotzdem vielen Dank fürs Verständnis:thumbup:


    Zum 1. muss ich gestehen, dass ich mit der Eröffnung dieses Beitrages zu voreilig war, denn noch war längst nicht alles getestet --> damit steht 2. fest, es sollte kein Fehler des Programms Loksim3D in Version 2.9.4 sein!

    Zum einen habe ich deine PN gelesen und werde dir die Tage antworten. Das kann aber etwas dauern da ich natürlich auch Zuhause Dinge zu erledigen habe.

    Das ist auch nicht dringlich und nur noch teilweise nötig, sowohl beim String für die Zeitanzeige als auch bei den Fahrplan-Variablen sind Fehler drin, die ich schon erkannt habe.

    Möchtest du die Zugzielanzeige mit dr Sichtbarkeitsteuerung ansteuern?

    Diese Aussage verstehe ich aber nicht, in Bezug auf die Doku? Möglicherweise gibt es noch andere Varianten so einer Zugzielanzeige das "Laufen" beizubringen.

    Was mir aber aufgefallen ist. Du hast ein Problem und man soll dir helfen.
    Da gehört es sich doch eigentlich das man dazu kommuniziert was man, womit, wie probiert hat,
    Also Loksim Version, Welches Addones in welcher Version wie und wo eingebaut.

    Im Eifer des Gefechts vergaß ich diese wichtigen Angaben, da stimme ich zu, sorry.

    Also Nachtrag: ZZA`s digital von JPB Version 1.1 (Download von Loksim-Homepage) speziell die Variante S5 mit Gleis ; Loksim-Version 2.9.4 zur Verwendung in einem privaten AddOn (das ich trotzdem NICHT preisgeben werde)!

    Das ich mir die Zeit genommen habe dir diese Infos aus der Nase zu ziehen ist meiner Gutmütigkeit geschuldet.
    Andere werden das nicht tun, und der Leidtragende bist dann du selbst.

    Hm...

    Jeder Mensch sollte etliche Chancen in unterschiedlichen Bereichen zugesprochen bekommen. Das nennt man LERNEN :thumbup:

    Also wenn man ein Problem hat und Hilfe sucht, mit Infos nicht geizen. Um so leichter hat man es ein Problem nachzuvollziehen.
    Und dann kann auch zeitnah und gezielt geholfen werden.

    Okay.

    doch die gemachten Eingaben im Objekt werden nicht übernommen/gespeichert,

    Warum das passiert ist, kann ich selbst nicht mehr reproduzieren, jedoch musste ich schon einige Male ein "Nichtspeichern"des Fahrplan-Editor feststellen, obwohl An-/Eingaben geändert wurden. Wenn es das nächste Mal soweit ist, werde ich versuchen es zu dokumentieren.


    Dann habe ich gleich mal noch eine Frage zu den ZZA´s:

    In der Doku wird sich nur mit dem nächsten anzuzeigenden Halt beschäftigt, der Zuglauf eines gewöhnlichen Personenzuges (z.B. S-Bahn) besteht aber nur selten aus Start- und Zielbahnhof.

    Wie man da weitere Halte hinzufügt, hätte ich gerne gewusst?

    Zudem möchte ich einen abweichenden "Namen" des letzten Haltes angezeigt bekommen, damit ich nicht die Halt-Namen aus der Streckendatei benutzen muss, wegen abweichender Schreibweise, speziell welcher Wert bei einer solchen Fahrplanvariabel einzutragen ist.


    Beste Grüße

    AndreL

  • Hallo André.


    Man kann sie ja auch statistisch mit festen Werten aufstellen. Ist natürlich nicht wirklich praktikabel aber ich wusste ja nicht was du vorhast. Deshalb nachgefragt um sicherzustellen das wir das gleiche Problem besprechen.


    Gruß André

  • Guten Abend an alle


    Zudem möchte ich einen abweichenden "Namen" des letzten Haltes angezeigt bekommen, damit ich nicht die Halt-Namen aus der Streckendatei benutzen muss, wegen abweichender Schreibweise, speziell welcher Wert bei einer solchen Fahrplanvariabel einzutragen ist.

    Dieses "Problem" ist mittlerweile auch keins mehr. Im Gegenteil, es ist äußerst "nett" anzusehen, wenn der Gegenzug auch das "richtige" Zugziel anzeigt.


    Beste Grüße

    AndreL

  • Hallo an alle


    Anbei 2 Screens die die verbleibenden "Restprobleme" mit den ZZA´s verdeutlichen sollen:


    Der Erste ist aus einem laufenden Testfahrplan heraus, musste nur relativ stark verkleinert werden, damit er hier ohne Bilderhoster angezeigt wird. Ich hoffe die Auflösung reicht noch.

    Der Zweite ist ein Teil der im Bau befindlichen Streckendatei und soll die Objekteigenschaften/den String des nächsten anzuzeigenden Haltes zeigen.Probleme:


    1. (bewusst durch mich provoziert) wenn man die Abfahrtszeit "verpasst", sprich den Fahrplan nicht einhält, zeigt der ZZA die Zeit bis zur selben Abfahrt am nächsten Tag an, hier 1438 min ???

    2. obwohl der in Screen2 dargestellte String nach Doku erstellt ist, zeigt der ZZA den nächsten Halt NICHT an ???

    Liegt es am Bedarfshalt?

    3. hat niemand eine Idee dazu???

    Wie man da weitere Halte hinzufügt, hätte ich gerne gewusst?


    Die Abbildungen dienen rein als Anschaungs- und Lernmaterial, da es diesen Zugzielanzeiger so dort im Original nicht auf diesem Bahnhof gibt.


    Beste Grüße

    AndreL

  • Hallo Andre,


    hast du die Eingaben des Zuglaufs schon ausprobiert, wenn du den nächsten Halt als Planhalt eingestellt hast?


    Wurden in der Fahrplandatei auch die nötigen Eingaben gemacht? Wenn nicht, dann probier mal aus, was passiert, wenn im Fahrplan unter "Benutzerdefinierte Variablen" bei "Name" das Wort "Zuglauf eingegeben wird. Vielleicht klappt es dann schon. Ansonsten kannst du mir die nötigen Dateien als Package schicken und ich schaue es mir an.


    Viele Grüße


    Dominik

  • Hallo Dominik


    hast du die Eingaben des Zuglaufs schon ausprobiert, wenn du den nächsten Halt als Planhalt eingestellt hast?

    Danke für den Tipp. Das probiere ich zeitnah.

    Wurden in der Fahrplandatei auch die nötigen Eingaben gemacht? Wenn nicht, dann probier mal aus, was passiert, wenn im Fahrplan unter "Benutzerdefinierte Variablen" bei "Name" das Wort "Zuglauf eingegeben wird.

    Ich ahne worauf du hinaus willst. Auch das wird getestet.


    Beste Grüße

    AndreL